MTGO and windows 10 not working for me

So I just got a new computer with Windows 10 on it and now the MTGO client crashes upon startup. I have contacted Wizards but none of their tips work (my .net version is the correct one etc). Has anyone else experienced problems with windows 10 and the MTGO client and, if so, how did you get them resolved?

I recently had this problem. The issue was, apparently, that the MODO faeries came into my house at night and magically broke my install, since it worked for a while and then stopped. I fixed it by redownloading a fresh setup.exe from their site and trying it all over. Good times.

Still don't know why it did that, is it giving you a framework error when it tries to update? That was my issue.

Edit - I just remembered that when I reinstalled, I put it on D:\ instead of C:, but I have no idea why that helped. Fresh install on C:\ had same error as before.

last edited by McAra

@McAra Unfortunately downloading a new setup-file doesn't work, I've tried it many times. The online support-chat thought it was a problem with the wrong version but nope, I have the right one. I can still use my old computer for MTGO but really need it to work on the new one too (don't want to drag two laptops with me on travels....)

How is the crash happening? No error message? Is it when you execute the program or shortly after? Does the little update window come up at all?

Oh and are you on a Mac? A friend of mine partitioned a huge amount of space for just Windows and MODO and eventually found that Windows had just eaten up every gig and that was why MODO was unhappy.

last edited by McAra

@McAra it starts loading and I see the login screen but then an error message (a long one) appears stating that there has been a fatal error and the program needs to shut down. I also have the option to send the error log to wizards, which have done. The log is really long and I am not able to pinpoint exactly what the proplem seems to be. I am using a Lenovo ThinkPad Carbon X1 so no Mac. I don't have a partition on the hard drive so can't test that solution.

Update: the error message says: Stack: at shiny.ShellViewModel.CreateSession()

last edited by kistrand

not sure if you still have the problem. but this usually due to cache data being corrupted so deleting the cache should solve your problem. Here are few tips from my blog. But point 6 should solve your problem. It's not Windows 10 issue, modo's been doing this for years, unless there is some problems with rights (modo not being able to write into that folder) . I have zero experience with Win10 though so I don't know how it behaves yet...

What to do when MODO starts to act up and it worked before the last update? In short ->

  1. Turn off firewall and antivirus software.
  2. Update operating system. (run Windows Update)
  3. Update .NET Framework (important)
  4. Uninstall Magic Online (run appwiz.cpl)
  5. Clear ClickOnce cache (run cmd -> type in this -> rundll32 dfshim CleanOnlineAppCache)
  6. Clear Magic Online Cache named 2.0 located at -> c:\Users[username]\appdata\Local\Apps\ (run %LocalAppData%\Apps)
  7. Download Magic Online from
  8. If MODO won't work after this contact Wizards of the Coast via their Customer Service (see screenshots above). Provide DxDiag file (run dxdiag) ->
  9. Wait and hope (next update might solve your issue).
  10. Change your computer configuration/ISP etc...

@stsung I've done all of these things. Seems to be a problem with Windows 10 education and the MTGO client since I tested installing the client on my brother's computer with Win 10 pro and it worked fine. Then I tested on another Win 10 education computer and the client crashed in precisely the same manner. The computer is currently getting windows 8.1 enterprise installed (which is the version I have on the old computer on which the MTGO client works). That ought to do the trick for now.

last edited by kistrand

SOLVED! I finally managed to get this issue solved myself. Just in case someone else will get this problem I'll write down the solution here. The issue was with something called FIPS security encryption which basically checks that every program applies to certain high-level security encryption standards upon launching said program. Most programs usually enforce an override of this upon installation but this for some reason was not the case for me whereby the FIPS algorithm threw out the MTGO client every time I tried to start it and caused a crash. The solution which eventually worked (I tried everything from re-installing windows to messing around in the regedit) was to right-click the MTGO icon, select the security tab-->advanced--->auditing and there click the "disable inheritance"-button, apply and happy times are back : )

last edited by kistrand

GJ, glad you managed to make it work. I personally would not expect anything like this to be the cause so it is good to know that something like this can possibly happen. Thx for sharing.

  • 9
  • 19813