ANNOUNCEMENT: archive.themanadrain back online - the old site, is now back up. I'll be disabling new posts, but you should be able to log into your old accounts, read old PMs, view old threads, etc.

Let me know if you have issues accessing the site - but any support issues regarding the archive site are much lower priority than TMD-proper.

last edited by Brass Man

Woohoo!! Muchas gratitudes, Andy!

Thank you very much, Andy.

Awesome! Thank you Andy!

im not able to connect to it ?
there is no 404 page its just like taking impossibly long to load in all my browsers.; Anyone else having the problem?

@JohnCJonesJr I'm currently able to see the archived Mana Drain with Chrome Version 50.0.2661.102 m

last edited by Aaron Patten

@JohnCJonesJr I'm seeing this too, though I definitely wasn't 2 days ago. I'll look into it but no guarantee of a quick turnaround for this one

Better late than never but thank you so much for keeping these pages live. There is simply so much on those old pages that for them to go dark it would have been heartbreaking.

Here in Australia I have been following up with the the owners of many of the Local forums from the late 20's and early '10's which have gone dark and in most cases it seems like we have simply lost all the data from those times. This includes Vintage but it is especially hard in the case of Australian 7pt Highlander which is obviously not played anywhere else.

Thank you once again.

for me isnt working, its like the site is there but the actual site is just white, am i the only one seeing this? or is the site still not working? im not sure if it matters but im currently on google chrome, have others been having this issue?

@letseeker It just worked for me a moment ago. Maybe it's on your end? I'm on whatever version of Chrome is the latest.

@mickey.nobilis i also tried it on microsoft edge, im not sure

Edit: it works on my phone so good enough

last edited by letseeker

Doesn't work for me on my desktops at work or home, nor on my phone. Would love to have access to the archive!!

last edited by 5space

@Brass-Man just wanted to up this for a work request. 🙂

Currently does not appear to be working in Windows 8.1 on any of the following browsers (latest versions of all):
Internet Explorer 11.0.9600.18378
Mozilla Firefox 47.0.1
Google Chrome 51.0.2704.103

It just displays a blank page in each, with zero lines of source code apparently.

It does currently work on Chrome Mobile 50.0.2661.89 (on Android 5.1.0).

@Brass-Man bumping this as a priority reminder this is still not working correctly on desktop browsers, and we would love to have access to this full time. Still not working in Windows 8.1 on any of the following browsers (latest versions of all 9/9/2016):
Internet Explorer 11.0.9600.18427
Mozilla Firefox 48.0.2
Google Chrome 53.0.2785.101 m

It just displays a blank page in each, with zero lines of source code. It is working Chrome for mobile 52.0.2743.98 (in Android 5.1.0).

@JACO This may be off-topic, but it works for me in Windows 7 SP1, although my browser autocorrects to stick a www prefix in front of that url. Can you try doing google site-specific searches to open up pages that way?

For example, you can try this google search: "merfolk" and it will bring up all old archived searches on merfolk.

Andy, I was wondering if you could use you're heavy weight status as TMD owner to talk to SCG and see if you can gain access to the old Vintage boards from their site. TMD was obviously better than SCG, but there is still some good stuff on there, like the "pimp proxy" thread as well as a lot of strategic discussion.

  • 17
  • 17725