Some features don't seem to be working

I've tried to flag posts for moderation and send a couple of chat messages. Neither of these worked for me. Are others able to do so? What specs would you need from me to help troubleshoot, @Brass-Man, if this is an individual problem?

@chubbyrain hmm... Is this desktop or mobile, when's the last time you're sure these features worked, those are the big ones. There was a software update not that long ago. I'll see if I can find anything.

@brass-man Desktop. 18 days ago was the last chat I made.


FWIW, I tried to report probably the same post(s), and couldn't either. I am also on Desktop.

EDIT: Just for further clarification: I do not see the option to report anywhere, it's an issue of being hidden or hard to find. It's not that I can find it and the button doesn't work.

last edited by FORCEOFNATURE

So there was a software update within that time window that may be responsible for this. Unfortunately I haven't found anything online about a bug or patch for this issue so it's going to require deeper investigation. Apologies for the annoyance! In the meantime, the best way to get ahold of me if TMD messaging isn't working is probably Twitter. ( @tmdBrassMan)

@FORCEOFNATURE the "report post" button should be in a menu you see when you click on the little three-dots icon on the lower right of a post. I'm seeing now that this menu doesn't even appear on mobile - I wouldn't be shocked if these issues all had the same root cause

@brass-man The only thing that appears in the drop-down menu for me is "Bookmark". "Report post" is not there. This is on desktop.

@nucleosynth I can see "Flag this post for moderation" on other people's posts, but not my own. I'm not sure if that's because I'm looking at my own post, or because I'm an admin. ... can anyone else confirm they're seeing similar behavior? (e.g. you can see "bookmark post" but not "flag post") - try looking at one of your own posts, and one of my posts, and someone else's posts.

@ChubbyRain is this what you saw? Did the "flag post" button not work, or was it just missing entirely? If people can't see this, it might be a permissions issue rather than a code issue ... makes it easier for me to investigate 🙂

@brass-man 0_1525104561004_4a22e36b-7ba0-405f-a5b7-ada7d10f2f60-image.png

On my own posts, I additionally have 'edit' and 'delete'.

last edited by nucleosynth

I had the Same issues for about a month until about a week ago. I'm always on mobile, either Android or iOS. I could only login and that was it. I couldn't use any features whatsoever which is mostly why I would visit the FB group more than here. Everything works for me now though.. so far.

I had formatting problems (as in lot of & and text markers) that required to reload the page multile times to fix and some buttons weren't working.
It's not happening anymore, but now if one enlarges the chat windows it covers only a tiny portion of the screen at the top.

last edited by Log

@ten-ten yeah, I patched the forum software not that long ago which could have both fixed your issue, and caused a new one. Still investigating this, but busy non-magic life right now so it might be slow going

last edited by Brass Man

@brass-man All the work you put into TMD Is appreciated, for sure. Thank you.

looks like the software update a few weeks ago silently broke the TMD custom theme, which caused the chat bug. That should be resolved now. I don't know if the post flagging issue has been fixed or not, please let me know!

Enlarged chat now covers almost the entire screen (it's even bigger than before), but this seems to have broken the windowed mode where messages are overlapping.
Just FYI. @Brass-Man

last edited by Log

I still do not see anywhere where I can "flag" the posts.

Thanks, I'll look into this. (In the meantime always feel free to message me on Facebook or Twitter if you see posts you think require moderation)

last edited by Brass Man

Once flagging posts is enabled again, I will make sure everyone in this thread knows.


(Yes. It’s a joke)

last edited by ribby

@Brass-Man Apparently chat is broken in another way now, when you enlarge it sticks to the top and it's impossible to send messages when windowed.
Also it's impossible to delete old conversations and notifications are not disappearing once read.

last edited by Log
  • 21
  • 10366